Essential - Increased latency on connections to the Connection Manager – Incident details
All systems operational
Increased latency on connections to the Connection Manager
Resolved
Degraded performance
Started 14 days agoJuly 06, 2026Lasted 19 minutes9:189:37 AMUTC
Affected
Connection Manager
Degraded performance from 9:18 AM to 9:37 AM
Updates
Resolved
UTC
Resolved
UTC
This incident has been resolved.
Monitoring
UTC
Monitoring
UTC
We implemented a fix and are currently monitoring the result.
Investigating
UTC
Investigating
UTC
We are currently investigating this incident, users may have issues when connecting to Essential, or attempting to perform tasks like purchasing cosmetics, messaging friends, etc.