Essential - Unable to connect to the Essential Network – Incident details

All systems operational

Unable to connect to the Essential Network

Resolved
Degraded performance
Started 5 months agoLasted about 1 hour

Affected

Connection Manager

Degraded performance from 9:31 PM to 10:34 PM

Updates
  • Resolved
    Resolved

    Most users should be able to access the Essential Network now. Some users may still encounter issues until Cloudflare fully resolves the incident, but we are not seeing request timeouts anymore. See the Cloudflare status page for more info.

  • Identified
    Identified

    It appears that Cloudflare is currently unstable in certain regions within Europe. This may prevent users from accessing the Essential Network, downloading updates for Essential, and more.

    We will update this status page with more information once we have it.

  • Investigating
    Investigating
    We are currently investigating this incident.