Essential - Essential Wardrobe not loading – Incident details
All systems operational
Essential Wardrobe not loading
Resolved
Major outage
Started 6 months agoLasted 29 minutes
Affected
Features
Major outage from 1:14 PM to 1:43 PM
Wardrobe
Major outage from 1:14 PM to 1:43 PM
Updates
Resolved
Resolved
This incident has been resolved. If you are still having issues with the Essential Wardrobe after restarting your game, please reach out to our support team in our Discord server.
Monitoring
Monitoring
We implemented a fix and are currently monitoring the result.
Identified
Identified
We are continuing to work on a fix for this incident.
Investigating
Investigating
We are currently investigating this incident. Users may not be able to open the Essential Wardrobe or view their owned cosmetics in-game.