Essential - Content Delivery Network unavailable – Incident details

All systems operational

Content Delivery Network unavailable

Resolved
Partial outage
Started 6 months agoLasted 12 minutes

Affected

Websites

Partial outage from 7:54 PM to 8:06 PM

cdn.essential.gg

Partial outage from 7:54 PM to 8:06 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved. If you are having issues loading cosmetics in-game or in the Wardrobe, please try restarting your game. If the issue persists, contact our support team in our Discord server.

  • Identified
    Identified

    Our Content Delivery Network (CDN) run by DigitalOcean is currently unstable. Requests to the CDN may take a long time to complete, or may fail entirely.

    Users may not be able to see cosmetics in-game or in the Wardrobe that they have not previously viewed.