Essential - Issues with connecting to the Essential network – Incident details
All systems operational
Issues with connecting to the Essential network
Resolved
Degraded performance
Started 8 days agoAugust 04, 2026Lasted 27 minutesAugust 04, 202610:2710:54 AMUTC
Affected
Connection Manager
Degraded performance from 10:27 AM to 10:54 AM
Updates
Resolved
UTC
Resolved
UTC
This incident has been resolved. If you're still having issues with connecting to the Essential network, please try restarting your game. If issues persist, contact our support team in our Discord server.
Identified
UTC
Identified
UTC
We have identified the problem and are working to resolve the incident.