Essential - General Connection Manager Instabilities – Incident details
All systems operational
General Connection Manager Instabilities
Resolved
Partial outage 70 %
Started 12 days agoJuly 01, 2026Lasted 32 minutes11:33 AM12:05 PMUTC
Affected
Connection Manager
Partial outage from 11:33 AM to 12:05 PM
Updates
Resolved
UTC
Resolved
UTC
This incident has been resolved.
Monitoring
UTC
Monitoring
UTC
We implemented a fix and are currently monitoring the result. Users may have issues when connecting to Essential, or attempting to perform tasks like purchasing cosmetics, messaging friends, etc.
Investigating
UTC
Investigating
UTC
We are currently investigating this incident. Users may have issues when connecting to Essential, or attempting to perform tasks like purchasing cosmetics, messaging friends, etc.