Essential - Connecting to the Essential Network and accessing other essential.gg services – Incident details

All systems operational

Connecting to the Essential Network and accessing other essential.gg services

Resolved
Degraded performance
Started 7 days agoLasted about 3 hours

Affected

Connection Manager

Degraded performance from 8:58 AM to 11:40 AM

Websites

Degraded performance from 8:58 AM to 11:40 AM

essential.gg

Degraded performance from 8:58 AM to 11:40 AM

cdn.essential.gg

Degraded performance from 8:58 AM to 11:40 AM

media.essential.gg

Degraded performance from 8:58 AM to 11:40 AM

Updates
  • Resolved
    Resolved

    We have implemented a fix for the issue.

    Users may still have issues connecting to the Essential Network or accessing essential.gg services. This is out of our control, and depends on how long it takes for your DNS provider or system to refresh its cache.

    We recommend trying Cloudflare's DNS if you are still having issues connecting to Essential.

  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Update
    Update
    We are continuing to work on a fix for this incident.
  • Identified
    Identified
    We are continuing to work on a fix for this incident.
  • Investigating
    Investigating

    Users may not be able to connect to the Essential network, or access any essential.gg services, due to an issue that we are investigating related to SSL.