Essential - Unable to connect to the Essential Network – Incident details

All systems operational

Unable to connect to the Essential Network

Resolved
Partial outage
Started 5 months agoLasted 11 minutes

Affected

Connection Manager

Partial outage from 11:26 AM to 11:37 AM

Updates
  • Resolved
    Resolved

    This incident has been resolved. If you are unable to connect to the Essential network, please try restarting your game. If problems persist after that, please contact our support team in our Discord server.

  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Identified
    Identified
    We are continuing to work on a fix for this incident.