Essential - Unable to connect to the Essential Network – Incident details

All systems operational

Unable to connect to the Essential Network

Resolved
Partial outage 30 %
Started 8 months agoLasted about 3 hours

Affected

Connection Manager

Partial outage from 11:49 AM to 12:20 PM, Degraded performance from 12:20 PM to 2:29 PM

Websites

Partial outage from 11:49 AM to 12:20 PM, Degraded performance from 12:20 PM to 2:29 PM

cdn.essential.gg

Partial outage from 11:49 AM to 12:20 PM, Degraded performance from 12:20 PM to 2:29 PM

Updates
  • Resolved
    UTC
    Resolved

    We have not observed any errors over the last hour in relation to our services. The Cloudflare incident is still on-going, but Essential is no longer affected: https://www.cloudflarestatus.com/incidents/8gmgl950y3h7.

  • Update
    UTC
    Update

    Our services appear to be accessible again, but Cloudflare have not provided an update for the incident. Users may still experience issues when connecting to the Essential network.

  • Monitoring
    UTC
    Monitoring

    Cloudflare are currently having issues, this may cause users to be unable to:

    • Connect to the Essential network

    • View cosmetics in-game

    • Update Essential through the auto-update feature