Scheduled for February 18, 2025 at 9:00 AM – 5:11 PM
Affects
Infrastructure
Under maintenance from 9:00 AM to 5:11 PM
Wardrobe
Under maintenance from 9:00 AM to 5:11 PM
Updates
Completed
February 18, 2025 at 5:11 PM
Completed
February 18, 2025 at 5:11 PM
The migration has completed. We have re-enabled coin and cosmetic purchases for all of our users.
If you believe that you are missing any cosmetics, or having issues purchasing coins, please reach out to our support team on our Discord server.
Update
February 18, 2025 at 4:52 PM
In progress
February 18, 2025 at 4:52 PM
The migration has completed. We are currently enabling coin and cosmetic purchases for portions of our users, and are hoping to enable it for all users soon.
Update
February 18, 2025 at 4:29 PM
In progress
February 18, 2025 at 4:29 PM
The maintenance is still in progress.
Update
February 18, 2025 at 4:28 PM
In progress
February 18, 2025 at 4:28 PM
The maintenance is still in progress.
Update
February 18, 2025 at 3:13 PM
In progress
February 18, 2025 at 3:13 PM
The maintenance is still in progress.
Update
February 18, 2025 at 1:10 PM
In progress
February 18, 2025 at 1:10 PM
The maintenance is still in progress.
Update
February 18, 2025 at 11:16 AM
In progress
February 18, 2025 at 11:16 AM
The maintenance is still in progress, but our Connection Manager is now stable and performing as expected.
The Wardrobe is still disabled. you will be unable to:
Purchase coins
Unlock cosmetics, emotes, and store bundles through the Wardrobe
Unlock cosmetics (Nitro Gem, Discord Cape) through our Discord Server
Update
February 18, 2025 at 10:13 AM
In progress
February 18, 2025 at 10:13 AM
Maintenance is now in progress
In progress
February 18, 2025 at 9:00 AM
In progress
February 18, 2025 at 9:00 AM
Maintenance is now in progress
Planned
February 18, 2025 at 9:00 AM
Planned
February 18, 2025 at 9:00 AM
We will be disabling parts of the Essential Wardrobe as we make infrastructure changes to improve its speed and stability.
You will be unable to:
Purchase coins
Unlock cosmetics, emotes, and store bundles through the Wardrobe
Unlock cosmetics (Nitro Gem, Discord Cape) through our Discord Server