Essential - Increased latency on connections to the Connection Manager – Incident details

All systems operational

Increased latency on connections to the Connection Manager

Resolved
Degraded performance
Started 16 days agoLasted about 1 hour

Affected

Infrastructure

Major outage from 7:44 PM to 7:52 PM, Degraded performance from 7:52 PM to 9:12 PM

Connection Manager

Major outage from 7:44 PM to 7:52 PM, Degraded performance from 7:52 PM to 9:12 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    Many users should be able to see cosmetic and emote updates in real-time. Certain users may still encounter delays when viewing other users' cosmetics and emotes.

  • Identified
    Identified

    We are currently investigating this incident, users may experience delays when viewing other players' cosmetics and emotes.

  • Investigating
    Investigating

    We are currently investigating this incident, users may have issues when connecting to Essential, or attempting to perform tasks like purchasing cosmetics, messaging friends, etc.