Essential - Purchased Essential Coins not being delivered – Incident details

All systems operational

Purchased Essential Coins not being delivered

Resolved
Degraded performance
Started 5 months agoLasted 38 minutes

Affected

Infrastructure

Operational from 6:31 PM to 6:31 PM, Degraded performance from 6:31 PM to 7:09 PM

Transactions

Operational from 6:31 PM to 6:31 PM, Degraded performance from 6:31 PM to 7:09 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved. Users that were waiting on their coins to be delivered, have been confirmed to have received them. If you believe that you are still missing coins from your purchase, please reach out to our Support Team on our Discord Server by opening a Support Ticket.

  • Monitoring
    Monitoring

    A fix has been implemented and we are monitoring the results.

  • Identified
    Identified

    The issue has been identified and a fix is being implemented.

  • Investigating
    Investigating

    We are currently investigating an issue related to users not receiving their purchased Essential Coins.